Định tuyến động với giao thức OSPF trên Router Cisco

0
408

Bài viết hướng dẫn cấu hình định tuyến sử dụng giao thức định tuyến OSPF để kết nối các LAN của hai chi nhánh với trụ sở chính trên các Router Cisco.

Công ty có 2 chi nhánh, 1 trụ sở. Hiện tại công ty đã thuê đường truyền riêng kết nối với hai chi nhánh thông qua Router Cisco nhưng hai chi nhánh hiện không thể liên lạc được với nhau.
Mô hình logic như sau:

image040

Các bước cấu hình định tuyến sử dụng giao thức định tuyến OSPF để kết nối các LAN của hai chi nhánh, trụ sở chính lại với nhau.
Cấu hình định tuyến OSPF trên các routers:

  •  Cấu hình trên router R1:
    • R1(config)#router ospf 1
    • R1(config-router)#network 172.16.1.16 0.0.0.15 area 0
    • R1(config-router)#network 192.168.10.0 0.0.0.3 area 0
    • R1(config-router)#network 192.168.10.4 0.0.0.3 area 0
  •  Cấu hình trên router R2:
    • R2(config)#router ospf 1
    • R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
    • R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
    • R2(config-router)#network 192.168.10.8 0.0.0.3 area 0
  •  Cấu hình trên router R3:
    • R3(config)#router ospf 1
    • R3(config-router)#network 172.16.1.32 0.0.0.7 area 0
    • R3(config-router)#network 192.168.10.4 0.0.0.3 area 0
    • R3(config-router)#network 192.168.10.8 0.0.0.3 area 0

Kiểm tra việc liên thông các mạng

  •  Dùng lệnh show ip route trên các router R1, R2, R3 để xem bảng định tuyến update có đúng chưa?
    • R1#show ip route

Cấu hình chứng thực OSPF:

  •  Kích hoạt tính năng chứng thực MD5 trong Area 0 trên cả 3 routers:
    • R1(config)#router ospf 1
    • R1(config-router)#area 0 authentication message-digest
    • R2(config)#router ospf 1
    • R2(config-router)#area 0 authentication message-digest
    • R3(config)#router ospf 1
    • R3(config-router)#area 0 authentication message-digest
  •  Kích hoạt chứng thực OSPF trên cổng s0/0/0 của router R1
    • R1(config)#interface s0/0/0
    • R1(config-if)#ip ospf message-digest-key 10 md5 secretpassword
  •  Sử dụng show ip ospf neighbor để xem các láng giềng của router R1
    • R1#show ip ospf neighbor

Cấu hình chứng thực OSPF tương tự trên các router R2, R3.

LEAVE A REPLY