Hướng dẫn cấu hình ACL để quản lý traffic mạng

0
285

Công ty TNHH Thiên Ân kinh doanh mỹ phẩm có hệ thống kinh doanh khá lớn.hệ thống mạng được mô hình hoá như hình dưới đây.
Công ty muốn cấu hình ACL để quản lý traffic mạng trên router cisco. Các công việc như sau:

  • Cấu hình để RT0 và RT2 ping RT3
  • Cấu hình để RT0 và RT2 telnet RT3
  • Cấu hình để ACL(Access- list) chặn các traffic từ RT0 đến RT3
  • Cấu hình để ACL chặn các ping từ RT2 đến RT3
  • Cấu hình để ACL chặn các telnet từ RT0 đến RT3
  • Cấu hình trên RT3 trong line vty để chỉ cho phép R telnet
image044

Cấu hình IP cho Interfaces:

  •  RT0:
    • RT0(config)#interface fa0/0
    • RT0(config-if)#ip add 10.0.0.10 255.255.255.0
    • RT0(config-if)#no shutdown
  • RT1:
    • RT1(config)#interface f0/0
    • RT1(config-if)#ip address 10.0.0.1 255.255.255.0
    • RT1(config-if)#no shutdown
    • RT1(config-if)#interface f0/1
    • RT1(config-if)#ip address 13.0.0.1 255.255.255.0
    • RT1(config-if)#no shutdown
    • RT1(config-if)#interface s0/0
    • RT1(config-if)#ip address 12.0.0.1 255.255.255.0
    • RT1(config-if)#no shutdown
  • RT2:
    • RT1(config)#interface s0/0
    • RT1(config-if)#ip address 12.0.0.2 255.255.255.0
    • RT1(config-if)#clock rate 64000
    • RT1(config-if)#no shutdown
  • RT3:
    • RT3(config)#interface f0/1
    • RT3(config-if)#ip add 13.0.0.3 255.255.255.0
    • RT3(config-if)no shutdown

Cấu hình để RT0 & RT2 ping RT3

  • RT0:
    • RT0(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1
  • RT2:
    • RT2(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.1
  • RT3:
    • RT3(config)#ip route 0.0.0.0 0.0.0.0 13.0.0.1

Cấu hình để RT0 và RT2 telnet được RT3:

  • RT3:
    • RT3(config)#line vty 0 3
    • RT3(config-line)#password 123
    • RT3(config-line)#login
    • RT3(config-line)#enable password 123

Cấu hình ACLs chặn mọi traffic từ RT0 đến RT3:

  • RT1:
    • RT1(config)#access-list 1 deny host 10.0.0.10
    • RT1(config)#access-list 1 permit any
    • RT1(config)#interface f0/1
    • RT1(config-if)ip access-group 1 out

Chặn ping từ RT2 đến RT3:

  •  RT1:
    • RT1(config)#access-list 100 deny icmp 12.0.0.0 0.0.0.255 13.0.0.0 0.0.0.255
    • RT1(config)#access-list 100 permit ip any any
    • RT1(config)#interface s0/0
    • RT1(config-if)#ip access-group in

Chặn telnet từ RT0 đến RT3:

  •  RT1:
    •  RT1(config)#Access-list 100 deny tcp host 10.0.0.10 host 13.0.0.3 ep 23
    •  RT1(config)#interface f0/0
    •  RT1(config-if)#ip access-group 100 in

LEAVE A REPLY