Hướng dẫn cấu hình HSRP trên Router Cisco

0
691

Tiếp nối loạt bài về Cisco. oktot.com gởi đến bạn bài Lab hướng dẫn cấu hình HSRP trên Router Cisco.
Cho mô hình sau:

image052

Các tác vụ yêu cầu như sau:

  1. Bật tính năng hỗ trợ HSRP trên R6 và R7, sử dụng địa chỉ ảo (virtual IP) 150.50.7.10. Ta nên đặt địa chỉ MAC ảo là 0001.0023.0456.
  2. Đảm bảo là R6 là active HSRP router, nếu R6 bị sự cố thì R7 sẽ trở thành HSRP router. Khi R6 kết nối trở lại thì R6 lại được là active router, thời gian chuyển trạng thái là 60 giây.
  3. R6 và R7 trao đổi gói tin hello cứ mỗi 20 giây, và đợi 60 giây trước khi thông báo router bị sự cố (down). Không thay đổi router priority trên R7.
  4. Cấu hình R6 và R7 để sử dụng chuỗi chứng thực của packattack cho chứng thực HSRP.
  5. Cấu hình HSRP trên Ethernet interface của R5, R6, and R7 với IP ảo 150.50.64.10. R5, R6, và R7 có thể sử dụng IP addresses trên Ethernet interfaces of 150.50.64/24 để đặt virtual IP nhưng không được trùng với IP của các host, và cũng không đặt trong vùng 150.50.7.0/25. Không sử dụng VLAN.
  6. Đảm bảo là R6 chỉ là active router nếu cả R5 và R7 bị sự cố. R5 là active router trong trường hợp thông thường.
  7. Nếu R5 bị lỗi và R7 trở thành active router, thì khi R5 kết nối trở lại sẽ ngay lập tức trở lại là active router.

Địa chỉ của các routers như sau:

Router 6: Ethernet 1/0 150.50.7.6 /25
Router 7: Ethernet 1/0 150.50.7.7 /25
Khi dùng HSRP, có thể có nhiều nhóm trên cùng một interface. Dùng lệnh show standby để xem các thông số của protocol HSRP. Độ ưu tiên mặc định của HSRP là 100. Router có độ ưu tiên cao hơn sẽ chiếm vai trò active.

Thực hiện chi tiết:
Router 6:

hostname r6
ip tcp synwait-time 5
no ip domain-lookup
interface Ethernet1/0
ip address 150.50.64.6 255.255.255.0 secondary
ip address 150.50.7.6 255.255.255.128
no ip redirects
standby 1 timers 20 60
standby 1 priority 255 preempt delay 60
standby 1 authentication packatta
standby 1 mac-address 0001.0023.0456
standby 1 ip 150.50.7.10
standby 1 track Se1/0 156
standby 2 ip 150.50.64.10
!
interface Serial1/0
ip address 150.50.100.6 255.255.255.224
encapsulation frame-relay
frame-relay lmi-type cisco

Router 5:

hostname r5
interface Ethernet0
ip address 150.50.64.5 255.255.255.0 secondary
ip address 150.50.7.5 255.255.255.128
no ip redirects
standby 2 priority 255 preempt
standby 2 ip 150.50.64.10
!
interface Serial0
ip address 150.50.100.5 255.255.255.224
encapsulation frame-relay

Router 7:

hostname r7
ip tcp synwait-time 5
no ip domain-lookup
interface Loopback0
ip address 200.0.0.7 255.255.255.255
!
interface Ethernet1/0
ip address 150.50.64.7 255.255.255.0 secondary
ip address 150.50.7.7 255.255.255.128
no ip redirects
standby 1 timers 20 60
standby 1 priority 100 preempt
standby 1 authentication packatta
standby 1 mac-address 0001.0023.0456
standby 1 ip 150.50.7.10
standby 2 ip 150.50.64.10
!
interface Serial1/0
ip address 150.50.5.68 255.255.255.224
no fair-queue

LEAVE A REPLY